System Requirements

Server and client requirements

Low client and server base requirements are core features that keep Foswiki widely deployable, particularly across a range of browser platforms and versions. Many extensions exist which enhance and expand Foswiki's capabilities; they may have additional requirements.

Server Requirements

The code is written in Perl 5, and uses a number of shell commands from perl. The default package requires RCS (Revision Control System), a GNU Free Software package. Foswiki is developed in a basic Linux/Apache environment. It also works with Microsoft Windows, and should have no problem on any other platform that meets the requirements.

ResourceSorted ascending Required Server Environment *
Cron/scheduler • Unix: cron
• Windows: cron equivalents
GNU diff GNU diff 2.7 or higher is required when not using the all-Perl RcsLite.
Install on PATH if not included with RCS (check version with diff -v)
Must be the version used by RCS, to avoid problems with binary attachments - RCS may have hard-coded path to diff
GNU fgrep, egrep Modify command line parameters in configure if you use non-GNU grep programs
GNU patch For upgrades only: GNU patch is required when patching the code using patches in diff format submitted by the community.
Perl 5.8.0 or higher (5.8.4 or higher is recommended)
RCS 5.7 or higher (including GNU diff)
Optional, Foswiki includes a pure perl implementation of RCS that can be used instead (although it's slower)
Web server Apache is well supported; see Foswiki:Support.InstallingOnSpecificPlatforms for alternative options.

Perl Modules

A complete list of the required and optional Perl modules can be found in lib/DEPENDENCIES.

Most of them will probably already be available in your installation. You can check version numbers with the configure script, or if you're still trying to get to that point, check from the command line like this:
perl -e 'use FileHandle; print $FileHandle::VERSION."\n"'

Client Requirements

The standard installation has relatively low browser requirements:

  • XHTML 1.0 Transitional compliant
  • Cookies, if persistent sessions are required
  • Javascript, for edit/save/upload functionality
    TIP Change {ValidationMethod}{Method} from strikeone to embedded in configure to allow non-javascript browsers to edit/save/upload

CSS and Javascript are used in most skins. Some skins will require more recent releases of browsers. The default skin is tested on IE 6, 7, Safari 3.0, and recent Mozilla based browsers (such as Firefox).

You can easily select a balance of browser capability versus look and feel. Try the installed skins at SkinBrowser and more at Foswiki:Extensions.SkinPackage.

Important note about Plugins

  • Plugins can require just about anything - browser-specific functions, stylesheets (CSS), Java applets, cookies, specific Perl modules,... - check the individual Plugin specs.


Related Topics: AdminDocumentationCategory
Topic revision: r1 - 12 Sep 2009 - 01:26:00 - ProjectContributor
 

This site is powered by FoswikiCopyright © by the contributing authors. All material on this site is the property of the contributing authors.
Ideas, requests, problems regarding Eugene Maker Space Wiki? Send feedback